CCNA Bangla tutorial-07 : ডায়নামিক রাউটিং কী এবং কিভাবে কনফিগার করতে হয়?

0
291
CCNA Bangla tutorial-07 : ডায়নামিক রাউটিং কী এবং কিভাবে কনফিগার করতে হয়?

titas sarker

আমি একজন মানুষ। আমার পরিবার আমার আশ্রয়। বন্ধুরা আমার আপনজন। আমাকে পাবেন এই লিংকে
https://www.facebook.com/titas.sarker
CCNA Bangla tutorial-07 : ডায়নামিক রাউটিং কী এবং কিভাবে কনফিগার করতে হয়?

Dynamic Routing
আজকে আমরা ডায়নামিক রাউটিং EIGRP নিয়ে  জানার চেস্টা করি। মনে রাখা ভাল যে সিসিএনএ পরীক্ষায় EIGRP নিয়ে একটি সিমুলেশন থাকে । সুতরাং EIGRP  খুবেই গুরুত্বপূর্ণ সিসিএনএ পরীক্ষার জন্য।

EIGRP  বেসিক ধারণা

EIGRP হলো এনহ্যান্সড ইন্টেরিয়র গেটওয়ে রাউটিং প্রোটোকল। ইহা এমন একটি প্রোটোকল যা আসলে লিংঙ্ক স্টেট রাউটিং প্রটোকলের বৈশিষ্ট্য আবার এটি ডিসট্যান্স ভেক্টর রাউটিং  প্রটোকলের অনেক বৈশিষ্ট্যই ধারণ করে। এসব বিবেচনা করে EIGRP বলা হয় হাইব্রিড রাউটিং প্রটোকল। এখন প্রশ্ন হলো ডিসট্যান্স ভেক্টর রাউটিং  প্রটোকল এবং লিংঙ্ক স্টেট রাউটিং প্রটোকল আসলে কি? ডিসট্যান্স ভেক্টর রাউটিং  প্রটোকলে এর  মাধ্যমে রাউটার জানতে পারে নেটওয়ার্কের প্রতিবেশী রাউটার সম্পর্কে  এবং সকল রাউটারের অবস্থান সম্পর্কে অথার্ৎ কতটুকু দূরত্বে রাউটার গুলো অবস্থান করছে। আর লিংঙ্ক স্টেট রাউটিং প্রটোকল এর মাধ্যমে রাউটার জানতে পারে প্রতিটি লিংকের কষ্ট সম্পর্কে এবং বেস্ট পাথ সিলেক্ট করে থাকে ।

EIGRP এর সুবিধাগুলো হলো,

  • CIDR ও VLSM সাপোর্ট করে
  • EIGRP টপোলজি টেবিলে ব্যাকআপ পাথ রাখে ফলে কোন পাথে কোন সমস্যা ব্যাপআপ পাথ দিয়ে যোগাযোগ করে।
  • DUAL(Diffusing Update Algorithm) ব্যবহার করে প্রতিটি রাউটারের মান নির্ধারণ করে।
  • ডিফল্ট হপ কাউন্ট হলো-১০০
  • প্রতিবেশি রাউটারগুলোর মধ্যে hello ম্যাসেজ পাঠায়। সেই hello  ম্যাসেজ এর উত্তরে জানতে পারে কোন রাউটার নেটওয়ার্কে একটিভ আছে । ফলে দ্রুত কনভার্জেন্স ঘটে।

চলেন এবার দেখি EIGRP  কিভাবে কাজ করে?

প্রথমেই EIGRP  প্যাকেট গুলো সম্পর্কে জানার চেষ্টা করি

১. হ্যালো – এই প্যাকেট এর মাধ্যমে প্রতিবেশী রাউটার  এর সাথে রিলেশনশীপ তৈরী করে থাকে।

২. আপডেট –  আপডেট ব্যবহার করা হয় রাউটিং টেবিলের আপডেট সেন্ড করার জন্য।

৩. কোয়েরি- যদি মেইন রাউট এ সমস্যা হয় তাহলে কোন ব্যাকআপ পাথ আছে কি না তা জানার জন্য কোয়েরি প্যাকেট সেন্ড করে।

৪. রিপ্লে- যদি কোন প্রতিবেশী রাউটার ব্যাপআপ পাথ প্রদান করে তা হলো রিপ্লে ম্যাসেজ প্রদান করে।

৫. একোনলেজমেন্ট- প্যাকেট রিসিভ করে একোনলেজমেন্ট প্যাকেট এর মাধ্যমে।

এখন দেখি কিভাবে রাউট আপডেট  করে

মনেকরি ২টি রাউটারে  EIGRP কনফিগার করা আছে। চলেন দেখি রাউটার ২ট অন করার সাথে সাথে কি ঘটনা গঠে

ধাপ-১: রাউটার-১ একটি হ্যালো ম্যাসেজ সেন্ট করবে রাউটার-২কে

ধাপ-২: রাউটার-২ হ্যালো ম্যাসেজ রিসিভ করে সে একটি হ্যালো ম্যাসেজ সেন্ড করবে রাউটার-১কে । রাউটার-২ সাথে রাউটিং আপডেট প্যাকেট সেন্ড করবে রাউটার-১ কে

ধাপ-৩: রাউটার-১ আপডেট প্যাকেট রিসিভ করার সাথে সাথে একটি এ্যাকুনলেজ ম্যাসেজ সেন্ড করবে রাউটার-২ কে  । সাধারণত এভাবেই EIGRP তার প্রতিবেশী রাউটার গুলোর সাথে যোগাযোগ রক্ষা করে থাকে ।

Route CCNA Bangla tutorial-07 : ডায়নামিক রাউটিং কী এবং কিভাবে কনফিগার করতে হয়?

এবার একটি প্রাকটিক্যাল করি অথার্ৎ EIGRP  কনফিগার করি

EIGRP  কনফিগার করার পদ্ধতি

১. প্রথমে নেটওয়ার্কটি ডিজাইন করি

২. প্রতিটি রাউটারের আলাদা নাম এসাইন করি।

৩. প্রত্যেকটি রাউটারে ইন্টারফেসগুলো আপ করি

৪. প্রতিটি রাউটারে EIGRP চালু করি।

১. প্রথমে নেটওয়ার্কটি ডিজাইন করি

Final pic CCNA Bangla tutorial-07 : ডায়নামিক রাউটিং কী এবং কিভাবে কনফিগার করতে হয়?

২.প্রতিটি রাউটারের আলাদা নাম এসাইন করি।

Dhanmondi router host name configuration

—————————————–
Router>

Router>en

Router#conf

Router#configure ter

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#host

Router(config)#hostname Dhanmondi

Dhanmondi (config)#exit

Dhanmondi #

%SYS-5-CONFIG_I: Configured from console by console

Dhanmondi #wr

Gulshan router host name configuration

——————————————-

Router>

Router>en

Router#conf

Router#configure ter

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#host

Router(config)#hostname Gulshan

Gulshan(config)#exit

Gulshan#

%SYS-5-CONFIG_I: Configured from console by console

Gulshan#wr

Uttara router host name configuration

—————————————————–
Router>

Router>en

Router#conf

Router#configure ter

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#host

Router(config)#hostname Gulshan

Gulshan(config)#exit

Gulshan#

%SYS-5-CONFIG_I: Configured from console by console

Gulshan#wr

 ৩. প্রত্যেকটি রাউটারে ইন্টারফেসগুলো আপ করি

Dhanmondi router interface configuration

———————————————————

Dhanmondi>

Dhanmondi>en

Dhanmondi#conf

Dhanmondi#configure ter

Dhanmondi#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Dhanmondi(config)#inter

Dhanmondi(config)#interface eth

Dhanmondi(config)#interface ethernet 0/0/0

Dhanmondi(config-if)#ip add

Dhanmondi(config-if)#ip address 172.16.0.1 255.255.0.0

Dhanmondi(config-if)#no sh

Dhanmondi(config-if)#no shutdown

%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up

Dhanmondi(config-if)#exit

Dhanmondi(config)#inter

Dhanmondi(config)#interface fast

Dhanmondi(config)#interface fastEthernet 0/0

Dhanmondi(config-if)#ip add

Dhanmondi(config-if)#ip add

Dhanmondi(config-if)#ip address 172.15.0.1 255.255.0.0

Dhanmondi(config-if)#no sh

Dhanmondi(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

Dhanmondi(config-if)#exit

Dhanmondi(config)#inter

Dhanmondi(config)#interface fast

Dhanmondi(config)#interface fastEthernet 0/1

Dhanmondi(config-if)#ip add

Dhanmondi(config-if)#ip address 192.168.1.1 255.255.255.0

Dhanmondi(config-if)#no sh

Dhanmondi(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

Dhanmondi(config-if)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Dhanmondi(config-if)#exit

Dhanmondi(config)#exit

Dhanmondi#

%SYS-5-CONFIG_I: Configured from console by console

Dhanmondi#wr

Gulshan router interface configuration

———————————————————–
Router>

Router>en

Router#conf

Router#configure ter

Router#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#host

Router(config)#hostname Gulshan

Gulshan(config)#exit

Gulshan#

%SYS-5-CONFIG_I: Configured from console by console

Gulshan#wr

Building configuration…

[OK]

Gulshan#

Gulshan#conf

Gulshan#configure ter

Gulshan#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Gulshan(config)#inter

Gulshan(config)#interface eth

Gulshan(config)#interface ethernet 0/1/0

Gulshan(config-if)#ip add

Gulshan(config-if)#ip address 172.17.0.1 255.255.0.0

Gulshan(config-if)#no sh

Gulshan(config-if)#no shutdown

%LINK-5-CHANGED: Interface Ethernet0/1/0, changed state to up

Gulshan(config-if)#exit

Gulshan(config)#inter

Gulshan(config)#interface fast

Gulshan(config)#interface fastEthernet 0/0

Gulshan(config-if)#ip add

Gulshan(config-if)#ip address 172.15.0.2 255.255.0.0

Gulshan(config-if)#no sh

Gulshan(config-if)#no shutdown

Gulshan(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

Gulshan(config-if)#exit

Gulshan(config)#inter

Gulshan(config)#interface fast

Gulshan(config)#interface fastEthernet 0/1

Gulshan(config-if)#ip add

Gulshan(config-if)#ip address 192.168.2.1 255.255.255.0

Gulshan(config-if)#no sh

Gulshan(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Gulshan(config-if)#exit

Gulshan(config)#exit

Gulshan#

Uttara router interface configuration

———————————————————

Uttara#conf

Uttara#configure ter

Uttara#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Uttara(config)#inter

Uttara(config)#interface eth

Uttara(config)#interface ethernet 0/1/0

Uttara(config-if)#ip addd

Uttara(config-if)#ip add

Uttara(config-if)#ip address 172.17.0.2 255.255.0.0

Uttara(config-if)#no sj

Uttara(config-if)#no s

Uttara(config-if)#no sh

Uttara(config-if)#no shutdown

Uttara(config-if)#

%LINK-5-CHANGED: Interface Ethernet0/1/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/1/0, changed state to up

Uttara(config-if)#

Uttara(config-if)#exit

Uttara(config)#inter

Uttara(config)#interface eth

Uttara(config)#interface ethernet 0/0/0

Uttara(config-if)#ip add

Uttara(config-if)#ip address 172.16.0.2 255.255.0.0

Uttara(config-if)#no sh

Uttara(config-if)#no shutdown

Uttara(config-if)#

%LINK-5-CHANGED: Interface Ethernet0/0/0, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0/0, changed state to up

Uttara(config-if)#

Uttara(config-if)#exit

Uttara(config)#inter

Uttara(config)#interface fast

Uttara(config)#interface fastEthernet 0/1

Uttara(config-if)#ip add

Uttara(config-if)#ip address 192.168.3.1 255.255.255.0

Uttara(config-if)#no sh

Uttara(config-if)#no shutdown

Uttara(config-if)#

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

Uttara(config-if)#exit

Uttara(config)#exit

Uttara#

%SYS-5-CONFIG_I: Configured from console by console

Uttara#wr

Building configuration…

[OK]

৪. প্রতিটি রাউটারে EIGRP চালু করি।

Dhanmondi router EIGRP configuration

——————————————————

Dhanmondi>

Dhanmondi>en

Dhanmondi#conf

Dhanmondi#configure ter

Dhanmondi#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Dhanmondi(config)#router

Dhanmondi(config)#router eig

Dhanmondi(config)#router eigrp 20

Dhanmondi(config-router)#net

Dhanmondi(config-router)#network 192.168.1.0

Dhanmondi(config-router)#net

Dhanmondi(config-router)#network 172.16.0.0

Dhanmondi(config-router)#net

Dhanmondi(config-router)#network 172.15.0.0

Dhanmondi(config-router)#exit

Dhanmondi(config)#exit

Dhanmondi#

Gulshan route EIGRP command line

—————————————————-
Gulshan>

Gulshan>en

Gulshan#conf

Gulshan#configure ter

Gulshan#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Gulshan(config)#rou

Gulshan(config)#router eig

Gulshan(config)#router eigrp 20

Gulshan(config-router)#net

Gulshan(config-router)#network 192.168.2.0

Gulshan(config-router)#net

Gulshan(config-router)#network 172.17.0.0

Gulshan(config-router)#net

Gulshan(config-router)#network 172.15.0.0

Gulshan(config-router)#

%DUAL-5-NBRCHANGE: IP-EIGRP 20: Neighbor 172.15.0.1 (FastEthernet0/0) is up: new adjacency

Uttara router EIGRP configuration

——————————————————————–
Uttara>

Uttara>en

Uttara#conf

Uttara#configure ter

Uttara#configure terminal

Enter configuration commands, one per line.  End with CNTL/Z.

Uttara(config)#ro

Uttara(config)#router ei

Uttara(config)#router eigrp

% Incomplete command.

Uttara(config)#router eigrp 20

Uttara(config-router)#net

Uttara(config-router)#network 192.168.3.0

Uttara(config-router)#net

Uttara(config-router)#network 172.16.0.0

Uttara(config-router)#

%DUAL-5-NBRCHANGE: IP-EIGRP 20: Neighbor 172.16.0.1 (Ethernet0/0/0) is up: new adjacency

Uttara(config-router)#net

Uttara(config-router)#network 172.17.0.0

Uttara(config-router)#

%DUAL-5-NBRCHANGE: IP-EIGRP 20: Neighbor 172.17.0.1 (Ethernet0/1/0) is up: new adjacency

EIGRP কনফিগারেশন শেষ। এখন আমরা এক হোস্ট থেকে অন্য হোস্টে পিং করে চেক করতে পারি । যদি পিং রিপ্লে হয় তাহলে বুঝতে হবে আমাদের EIGRP কনফিগারেশন সঠিক হয়েছে। আজকের মতো তাহলে এখানেই শেষ করছি।Ping test1 CCNA Bangla tutorial-07 : ডায়নামিক রাউটিং কী এবং কিভাবে কনফিগার করতে হয়?

 

একটি উত্তর ত্যাগ